Guide for deploy node in testnet

Hi all, we deployed our node in testnet and decided share the guide.

“Deploy NuCypher’s node in testnet” by Natali https://link.medium.com/2L6Pf5ogQ0

I tried these steps on my windows PC. Worked fine up to activate command. Next step pip3 install fails mainly at building wheel commands. Also command x86_64 Linux -gnu-gcc.
Any ideas?
Thanks for this guide!

Try this

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install python3-dev

And after that install nucypher

pip3 install -U nucypher

Thanks for your reply. I tried that already. But no go. Same result.

You can try this

sudo apt install build-essential python3-pip

Not sure how to thank you mate! Worked. I can now run help command ok. Let me proceed … Thanks again

Thanks very much for your wonderful helps. My node is up and running!!

My congratulations :+1:

Thank you😇. I have a problem now. Yesterday it was ok. If I try to open the browser ext/ip :9151/status, can’t open it. Can’t be reached. I have port forwarding rules and firewall rules set. Ursula status returns alright. Whats wrong? When I check netstat -ano, ip status for port 9151 is close_wait…

Just realised my external ip has changed. How can I change that now ,:clown_face: